How To Setup TunerStudioMS

Before beginning the procedure this article outlines, please be sure that that you have already downloaded and installed our software package to your tuning laptop, and you have installed firmware into your MegaSquirt ECU.

Step 1. Plugging up.

If you just finished installing firmware to your MegaSquirt ECU, you probablly are already powered up and connected to your tuning laptop. If not, let’s go ahead and connect your MegaSquirt ECU to your laptop and supply 12 volts. The easiest and safest way to do this would be to use our 12V power supply and/or with a Stimulator if you’re just getting familiar with the ECU.  You can do this with your MegaSquirt in your vehicle connected to vehicle power.  You’ll want to make sure your ignition settings are correct before powering up the ECU connected to the car however.

Step 2. Open the tuning software.

With the MegaSquirt ECU now powered up and connected to the laptop, open up your Windows menu and browse over to your program files. We will want to open the MegaSquirt folder and start the program called TunerStudio MS.

Step 3. Basic configuration

After TunerStudio opens, mouse over to the File menu. We will want to open File > Project > New Project. This will open the Create New Project Menu. Add a project name, any name you want. I recommend using the firmware version loaded into your ECU as part of the description. For example, I have called my project 95M Miata 2.1.1.

After naming your project, let’s click on the Detect button on the middle, right side of the Create New Project menu.

Clicking this button will ask TunerStudio to find the MegaSquirt that is connected to your laptop, and will identify the com port number and firmware version loaded to the ECU. After TunerStudio calls out the com port number and ECU firmware definition, click Accept.

To set the ECU Definition, TunerStudio will need to match up your ECU’s firmware to its corresponding ini file that is saved on your laptop. This may happen automatically. However if TunerStudio does not find the coresponding .ini file, you will need to set it up manually.

Step 4. Setting up ECU Definition

A. Automatically

If TunerStudio is able to detect your ECU Definition automatically, just click Accept and skip to step 5.

B. Manually

If TunerStudio does not automatically find the correct .ini file, it will pop up a dialog box saying that the configuration file was not found locally and ask you if you want it to look on the web for the file. Click No on this box. We’ll point TunerStudio to this file manually.

On our Create New Project menu, click on Other and then the � button under Detect. This is going to open up our windows broswer.

You will need to browse over to the firmware definition folder that you previously uploaded to your MegaSquirt. Generally these will be found in your C/Program Files/MegaSquirt directory, but could be stored elsewhere depending on where you have chosen to save files. Because I loaded MS2E 2.1.1 to my ECU, I will open the 2.1.1 folder, and then chose the .ini file inside the folder. Then click Next> on the Create New Project menu. This will set our ECU definition.

Important NOTE** There could be multiple .ini files to select in some firmware versions. This is to allow for the differences in code between MegaSquirt and MicroSquirt ECUs. Not all firmware versions will have multiple .ini files, but if yours does, be sure to chose the correct one. Use the MS file if you have a MegaSquirt ECU, or use the uS file if you have a MicroSquirt. A DIYPNP is a MicroSquirt-module based EMS so you’ll use the MicroSquirt Module settings. On 3.3.0 and later code, MSPNPs have their own INI file to reflect their standard port settings.

Step 5. Project Properties.

Now we will set up our project’s properties. You can set your o2 sensor type for narrowband or various wideband sensors, temperature in Fahrenheit or Celsius, as well as other preferences.

On MS2/Extra 3.2.5 and earlier code, we will also need to set up TunerStudio for a MegaSquirt or MicroSquirt ECU. We will do this by using the dropdown menus called MICROSQUIRT_FULL and MICROSQUIRT_MODULE. Please follow the below chart for the proper settings:

ECU Type

MICROSQUIRT_FULL

MICROSQUIRT_MODULE

MegaSquirt

Deactivated

Deactivated

DIYPNP

Deactivated

Activated

MicroSquirt ECU

Activated

Deactivated

MicroSquirt Module

Deactivated

Activated

Note that MS2/Extra 3.3.0 and later code addresses this with different firmware build variants with different INI files, making the MicroSquirt and MicroSquirt Module settings unnecessary. The same goes for MS3 firmware 1.2.0 and later, which has separate firmware for the MS3-Pro and for the MS3 V3.0 / V3.57.

On the other settings, as a general rule, use the default if you are not sure if you need it. Most of these are advanced options that many users will not need.

Click Next> when finished

Step 6. Confirming Settings

We’re almost there. TunerStudio is simply confirming our configuration. It’s repeating back the project name, the com port that your MegaSquirt ECU is connected to, and the baud rate of the communication. This should be set to 9600 for an MS1 or 115200 for MS2 or MS3. If this all looks good, click Next>

Step 7. Choosing a Dash Configuration

TunerStudio has a large variety on how it can display your virtual dashboard. Here you can chose from a few different preset gauge types. Chose the one that looks best to you, and click Finish. If you have trouble deciding, this is something you can always change later.

Congratulations, your TunerStudio project is ready to go, and you are ready to start configuring your basemap.